SparkLabs Forum.

Community Help.


Bundling Viscosity on MacOS High Sierra does not work

I was trying to build a new install package following this guide:
https://www.sparklabs.com/support/kb/ar ... ences-mac/

I installed Packages, downloaded your viscosity_installer.tgz template installer package and of course downloaded the latest version of Viscosity.

I followed all the steps, first installed Viscosity, then added Settings (including only a license key), and also added 1 connection to the template folders

I open up the project file in Packages and Build, and I get no errors everything seems to work just fine.

Now the problem:
When I test this new package, (first uninstall the existing Viscosity version) and then run the new install package I just created everything seems to work just fine as well, I get no errors at all.. .but Viscosity.app is never placed in the Application folder.

It seems like the connection included in the package is added just fine to the corresponding Library folder etc, but the actual application is never added to the application folder.

As far as I can tell this is happening because I am creating this package on a computer running MacOS: High Sierra (10.13.3)
I have build these packages before (for instance for Viscosity 1.7.5) but at that point it was on a Mac running El Capitain, I don't have access to that anymore.

Right now I'm trying to build a package with viscosity 1.7.6 and on a Mac running High Sierra and it just will not work no matter what I try it seems.

Could it possibly be that Apple changed things up again with their latest updates that require a change of your package template, or am I missing something obvious? :)
Hi JdZ,

Is Viscosity already present on the machine you’re testing the installer on? If so, and Viscosity is in a different location, the installer will automatically find that copy and perform an "upgrade" instead, rather than install an additional version to the Applications folder. I’d recommend running your installer on a fresh machine/VM and see if Viscosity gets installed to the correct location.

It is possible to turn off this behaviour by editing the installer project in the Packages application and removing any locators:
http://s.sudre.free.fr/Software/documen ... oad.html#4

Cheers,
James
As mentioned in my original post
"When I test this new package, (first uninstall the existing Viscosity version) and then run the new install package"

So as long as Viscosity is removed when I remove it this should not be the reason as I understand it .

And Viscosity has only been installed in the default location on this computer before I removed it .

I also tried a previous pkg package I made and that installed just fine.
3 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy